test
Incident Report for VUSD Student Learning Systems
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 23:21 PST
Update
We are continuing to investigate this issue.
Posted Feb 02, 2021 - 21:30 PST
Investigating
We are currently investigating this issue.
Posted Feb 02, 2021 - 21:28 PST
This incident affected: VUSD Website.