PowerSchool RTI System Down
Incident Report for VUSD Student Learning Systems
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 09:02 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 20, 2021 - 15:43 PST
Identified
We are experiencing trouble with the RTI system in PowerSchool. Please do not enter any data into the RTI system until further notice. The rest of PowerSchool should be operating normally.
Posted Jan 20, 2021 - 15:39 PST
This incident affected: PowerSchool Student, Parent and Admin Portal.